Wed, 28 May 2008

i386/amd64 d-i images for Etch, kernel version 2.6.25 + firmware + WPA support

Yesterday I updated my Etch d-i to use Linux kernel 2.6.25. You can download it from the usual place.

In this version, I merged newest WPA support patch was created by Glenn into netcfg and wpasupplicant (thank you very much, Glenn!). Although I haven't tested yet, I hope it works. Because Glenn already started to collaborate with d-i team about his work, I believe Lenny or EtchAndAHalf will have this cool feature soon.

This kernel 2.6.25 package is as same as one of Debian unstable. I modified the files of kernel-wedge and di-linux-2.6-*. See my SVN for details.

Comments

Ohww. .YEAHHH... thank you very very much, you are the best..
Im going to install tonight.

Posted by Louis at 2008/05/29 (Thu) 21:15:06

it is very best

linux-headers-2.6.25-2-common
not found :(

Posted by Vitaly at 2008/05/30 (Fri) 09:07:39

it is very best

linux-headers-2.6.25-2-common
not found :(

Posted by Vitaly at 2008/05/30 (Fri) 09:12:18

Oops. I'll fix it by next version.
Until that, please download from:
http://kmuto.jp/debian/d-i/2.6.25/linux-headers-2.6.25-2-common_2.6.25-3_i386.deb
http://kmuto.jp/debian/d-i/2.6.25/linux-headers-2.6.25-2-common_2.6.25-3_amd64.deb

Posted by kmuto at 2008/05/30 (Fri) 09:45:39

update:

I updated ISO images (and links) including correct linux-headers-*-common package.
Therefore I remove deb files what I wrote before.

Posted by kmuto at 2008/05/30 (Fri) 23:09:00

fat utf8 charset not supported

i'm trying to do a usb install but when it searches for the iso image it fails to load it.
i found that actually the image cannot be mounted because of this error:

Unable to load NLS charset UTF8
FAT: IO charset UTF8 not found

Posted by hybris at 2008/06/17 (Tue) 23:07:24

hybris,

Thanks for your pointing, I didn't notice it.
Although I haven't tested yet, I updated hd-media image with including nls_utf8.ko.

Posted by kmuto at 2008/06/22 (Sun) 20:02:51

Hi,

my friend bought a new Lenovo computer, which seems to be about the same as Lenovo 3000 (the machine was bought in India and it has got a bit different labels than 3000 but the manual is for 3000). Does your new kernel release work with the dvd drive and with the net card as normally fitted with these Lenovo 3000 computers? I already started to download the etch-custom-0622.iso. The connection is very slow from Delhi...

Posted by Hannu Virtanen at 2008/07/07 (Mon) 16:10:28

Hannu, I hope so.

Posted by kmuto at 2008/07/08 (Tue) 10:50:06

Hi,

Just trying to install amd64 etch-custom-0622.iso to a Dell PowerEdge 2950 with two Broadcom NetXtreme II network cards (driver bnx2) but the debian installer canot detect/configure any of them. After some searching found the following
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=487228
which explains and hopefully resolves the bug.

I'd like to ask if it is possible to patch your iso build according to the link above (or give me a hint to do it myself).

Thank you

Posted by dvg at 2008/07/14 (Mon) 06:21:31

Muchas Gracias


Felicitaciones por tu trabajo. Justo estaba buscando soporte del n炭cleo 2.6.25 para una placa nueva AMD 64 bits, con la cual tengo problemas con los drivers nVidia para Sata II.

臓 Un abrazo !

PD: Ya estaba pensando remasterizar un instalador Lenny, de los 炭ltimos (snapshot). Me ahorraste el trabajo.

Posted by Sergio at 2008/07/15 (Tue) 07:38:34

rt61 wifi

Hello,

Do you have an idea if this kernel supports out of the box the rt61 module used from some Linksys wireless cards?

Thanks a lot

Posted by Stelios at 2008/07/15 (Tue) 21:03:47

Thank you for providing this to the community.

I used your 1013 build with the 2.6.23-1-686 kernel to solve a problem where my sata dvd drive and my ethernet card were not visible to the standard debian installation.

However this build does not have the stallion.c driver compiled into the kernel. Was this driver left out on purpose? Do you know if I can add it back in? I need my sata dvd, my ethernet AND my stallion card to all work at the same time...

Thanks in advance for your help!! You are the best!

George

Posted by georgew at 2008/07/25 (Fri) 05:08:35

多Mistake?

Hello Kenshi:

I've reading your "howto" text file to replace the kernel and it talks about running the "./mtu.update". Did you forget to commit into the subversion repository?

Previously it says that we have to copy my own kernel packages (if they exist) to the "mtu/" folder (which doesn't exist).

Thanks in advance.

Jose

Posted by Jose at 2008/10/23 (Thu) 15:46:44

多Mistake?

Hello Kenshi:

I've reading your "howto" text file to replace the kernel and it talks about running the "./mtu.update". Did you forget to commit into the subversion repository?

Previously it says that we have to copy my own kernel packages (if they exist) to the "mtu/" folder (which doesn't exist).

Thanks in advance.

Jose

Posted by Jose at 2008/10/24 (Fri) 16:52:20

Hi Jose,

I forgot it. Committed.

Posted by kmuto at 2008/10/25 (Sat) 07:50:52

Thanks!

Posted by Jose at 2008/10/29 (Wed) 22:48:43

Little question...

Hello Kenshi:

I'm running the make command and, after a while, a get the following message:

"missing module zlib_inflate
command exited with status 1"

I presume I'll get more messages like this one. So, my question is..

How could I add any modules to this debian customizable CD system you created?

Thanks ins advance.

Jose

Posted by Jose at 2008/11/10 (Mon) 19:51:09
Write a comment

Message: Ready to post a comment.