Kernel.org: 5.4.2
sid (unstable): 5.3.15-1
buster (testing): 4.19.67-2+deb10u2
stretch (stable): 4.9.189-3+deb9u2
jessie (oldstable): 3.16.76-1

Debian GNU/Linux device driver check & report

ASUS: K50C

PCI IDWorks?VendorDeviceDriverKernel
10390671YesSilicon Integrated Systems [SiS]671MXsis-agp
10390003YesSilicon Integrated Systems [SiS]AGP Port (virtual PCI-to-PCI bridge)sis
10390968Silicon Integrated Systems [SiS]SiS968 [MuTIOL Media IO]
10395513YesSilicon Integrated Systems [SiS]5513 IDE Controllerpata_sisv2.6.25-
10397001YesSilicon Integrated Systems [SiS]USB 1.1 Controllerusb-ohci,ohci-hcd
10397001YesSilicon Integrated Systems [SiS]USB 1.1 Controllerusb-ohci,ohci-hcd
10397002YesSilicon Integrated Systems [SiS]USB 2.0 Controllerusb-ehci,ehci-hcd
10391183YesSilicon Integrated Systems [SiS]SATA Controller / IDE modesata_sisv2.6.28-
1039000aSilicon Integrated Systems [SiS]PCI-to-PCI bridge
1039000aSilicon Integrated Systems [SiS]PCI-to-PCI bridge
10397502YesSilicon Integrated Systems [SiS]Azalia Audio Controllersnd_hda_intelv2.6.25-
10390004Silicon Integrated Systems [SiS]PCI-to-PCI bridge
10396351Silicon Integrated Systems [SiS]771/671 PCIE VGA Display Adapter
168c002bYesQualcomm AtherosAR9285 Wireless Network Adapter (PCI-Express)ath9k
10ec8168YesRealtek Semiconductor Co., Ltd.RTL8111/8168/8411 PCI Express Gigabit Ethernet Controllerr8169

I have to say, that I very very want to install some Linux distribution on my laptop, but my machine very old and it have SIS Mirage 3 Graphics video card. I have tested the latest releases of Ubuntu and openSUSE and I just can not take some normal resolution. I think that Ubuntu and openSUSE already not supporting my video card and their drivers aren't helping me. I hope that after I will install Debian, I will have good resolution. But if I will not, please, just think about supporting my video card. (2014-11-17T04:09:18+00:00)