Kernel.org: 5.4.2
sid (unstable): 5.3.15-1
buster (testing): 4.19.67-2+deb10u2
stretch (stable): 4.9.189-3+deb9u2
jessie (oldstable): 3.16.76-1

Debian GNU/Linux device driver check & report

HP: DV6 1230eS

PCI IDWorks?VendorDeviceDriverKernel
10024383YesATI Technologies IncSBx00 Azalia (Intel HDA)snd-hda-intelv2.6.25-

Funciona perfectamente, incluso altavoces y headphones con 2.6.31 y añadiendo
"options snd-hda-intel model=dell-m4-1 enable_msi=1" 
en /etc/modprobe.d/alsa.conf (gentoo)
++++++++++

Works perfectly in gentoo 2.6.31 adding
"options snd-hda-intel model=dell-m4-1 enable_msi=1"
in /etc/modprobe.d/alsa.conf
 (2009-10-12 19:56:43)